[BL] Installing BL3 on HD - Victory!

baslinux at lists.ibiblio.org baslinux at lists.ibiblio.org
Mon Feb 25 10:55:57 EST 2008


Now I have BL3 installed to HD and it boots ok.
Let me resume my steps:
- Boot from floppies 1 and 2;
- fdisk -l   (just to have a look at the partition table and see what's
going on there)
- fdisk /dev/hda   (to start partitioning my DEVice /hda, which stands for
C: if it was DOS)
- fdisk option "n" allowed me to start a New partition, followed by "p" for
"primary" and "1" for the first ;
- fdisk option "n" again to make another partition, "p" for "primary" and
"2" for the second ( I understand this  is    merely optional - I wouldn't
need a second partition, right? )
- fdisk option "w"   Wrote the partition table

As suggested by the system, I run e2fsck /dev/hda1  and it say that
something was "clear" . I understood it as "OK"
Then I run   mke2fs /dev/hda1    in order to put an ext2 file system on  my
/dev/hda1 partition
Next step was mounting, by   mount /dev/hda1 /hd
Now, install-to-hd ENTER   (simply like this)
I heve put floppy1 on tge drive and  reboot
When "LILO" started to appear, I pressed CTRL and I was prompted with "BOOT:
"
The I've commanded    hd root=/dev/hda1
( This is where I was making  it the wrong way:  I was typing "hd
root=/dev/hda1  /HD" )
The system made itself a lot of procedures and gave me the welcome screen.
At that point I commanded  lilo -v
Followed by  fdisk /dev/hda , option "a", "1", "w"  which made that
partition bootable.
OK, now it boots from HD .

But  if  I did   hda1   bootable by the first time I wrote the partition
table   instead of making it by last?
Did it work the same way?

Thanks,
Teixeira





More information about the BasLinux mailing list