[BL] ) re: BL] ATA100 IDE-PCI controller card

baslinux at lists.ibiblio.org baslinux at lists.ibiblio.org
Sun Feb 17 16:58:34 EST 2008


On Sun, 17 Feb 2008, baslinux at lists.ibiblio.org wrote:

> Before it hangs, it says, in part
>
> -----------------------------
>
> ide1 at 0x170-0x176, 0x376 on irq15
>
> VFS: Cannot open root device 03:08
>
> Kernel panic: VFS: Unable to mount root fs on 03:08


Have you tried using the special kernel that I compiled for this 
controller?   I also posted modules for the same 2.4.31 kernel.
http://keesan.freeshell.org/bl/2.4.31/bzimavps.431

v - via
p - promise
s - sis

The kernel has drivers for these three common fast IDE controllers.

If you connect the hard disk to the add-in controller it is no longer hda, 
it is probably hde (or f, g or h).  You will need to make the devices with 
mknod - hde, hde1 2 ... 8.

BL does not even come with extended partitions for anything but a.
(I see hda1 through 9 in BL2, but had to make my own hdb5 and hdb6).

I forget what happens if you disable the onboard controller (other than 
the CD-ROM drive is said not to work with the add-in controller).  It may 
change the drive letters so the primary master on the card is hda again.

I think even with the correct drive designation I needed the driver in the
kernel in order to boot linux from that partition, otherwise it would not 
find the drive.  (The onboard VIA and SIS controllers worked without the 
special drivers, but at about 1/10 expected speed.  I think one or maybe 
both of these would work only compiled into the kernel, unlike the nforce 
which could be added as a module but was not very fast).

I think I flashed the BIOS on this card, I forget why.  Read my postings.

  > > ------- Forwarded message follows -------
>
>>> baslinux at lists.ibiblio.org baslinux at lists.ibiblio.org
>> Wed Oct 17 09:49:04 EDT 2007
>
> Sindi had said as follows (mostly snipped):
>
>> So we put in a Promise Ultra100 controller card
>
> I just did the same.
>
>> Linux booted using the onboard controller, but with the PCI-IDE
>> controller cannot open /dev/hda or any other hard drive when I boot
>> with 2-floppy BL3, and won't boot at all from hard disk (BL2 ramdisk,
>> BL3 loop, ext2 BL  - boot process stops partway through).
>
> I'd had BL 3.5 installed to /dev/hda8, and it worked fine when the HD
>
> was connected to the motherboard IDE:
>
> (part of GRUB's menu.lst:)
> ------------
> title Windows
> root (hd0,0)
> chainloader +1
> makeactive
> boot
>
> title BL 3.5
> root (hd0,0)
> kernel /baslin/zimage root=/dev/hda8 rw
> ------------
>
> But when it's plugged in to the ULTRA100 controller,
> what I got was kernel panic - it can't seem to find something it
> needs ?
>
> Can some Linux expert please help?


I am not an expert but I hope this helps.  I spent days searching the 
internet for the answer.
Sindi

>
> Thanks,
>
> Sheldon
>
>
> ------- End of forwarded message -------
>
> -----------------------
> BasicLinux mailing list
> -----------------------
> http://www.basiclinux.com.ru
> http://www.ibiblio.org/pub/linux/distributions/baslinux/
> ------------------------------------
> To exit, send subject=unsubscribe to
> baslinux-request at lists.ibiblio.org
>

keesan at sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org



More information about the BasLinux mailing list