[BL] 40 columns and PDA as terminal

baslinux at lists.ibiblio.org baslinux at lists.ibiblio.org
Sat Feb 2 00:42:20 EST 2008


>
> In theory you can use the PDA connection cable (which is apparently a
> nullmodem cable) alone with the PDA in terminal mode 
> to run BL on a PDA connected to a PC.

I cannot get dumb terminal mode to work with BL2 tonight.

> To use an external terminal you need to
> edit inittab.  BL2 comes with the required line in inittab but BL3.4 and
> BL3.5 do not.
>
> In BL2:
> c4:1235:respawn:/sbin/agetty 38400 tty4 linux
> (virtual terminal No. 4)
> #s1:12345:respawn:/sbin/agetty -L 19200 ttyS0 vt100
> (uncomment #s1 to use the serial port with nullmodem and dumb terminal 
instead of with mouse or camera or pilot-link file transfers or modemless 
telnet with intelnet.d)

I uncommented the line in inittab and rebooted first.  The serial port now 
no longer works for PDA file transfers (it still did before I rebooted, I 
think this is correct), and ps tells me: /sbin/agetty -L 19200 ttyS1 vt100
The desktop serial port is com2 (there is a serial trackball in com1) and 
it works with this cradle for pilot-link transfers.

I set line ttyS0 (only comport on the PDA), speed 19200, N81, 
serial=terminal (rather than telnet) mode all as instructed in the 
excellent instruction file for the free ptelnet 0.61 (pvterm and mocha 
telnet don't see to have terminal/serial mode).

In DOS Kermit I added at the end of mscustom.ini 'define modem none' (not 
define_modem none as I once posted about this).  Linux kermit requires set 
carrier-watch off instead.

I tap ON on the PDA or type C to Connect with DOS kermit on laptop and get 
a blinking cursor ___but no login prompt___.

Ptelnet terminal/telnet program (which can also dial directly via serial 
port like kermit) says blinking cursor and black ON mean you are 
connected.  Disconnecting (tap ON again) stops the blinking.

The laptop is an oddball Compaq 133Mhz where the serial port is Com3 (dead 
onboard modem and infrared are probably com1 and com2).
Loop BL3 crashes it (pages and pages of error messages) so I cannot check 
with microcom or C-kermit (linux kermit).

The cradle is a nullmodem cable and the instructions said to plug it in 
directly to the serial port. (For modem connection you need a nullmodem 
adaptor, which makes it into a regular modem cable).

This PDA dialed the ISP and telnetted and ssh'ed properly (with two other 
programs, not this one) and it transfers files via this same cradle using 
pilot-link, to the PDA and from it.  The laptop worked earlier with an 
external modem (but fails a loopback test, probably because the program 
is confused).  All the hardware seems to be okay (other than loop BL3 also 
not liking the laptop).  We cannot get into BIOS because it is not there 
(you need to make a BIOS partition and load some program onto it).

I tried the laptop in a second desktop computer, same blinking cursor.

What step did I leave out?

I will try the telnet method with intelnet.d and the inittab line 
commented back out.

Sindi




More information about the BasLinux mailing list