[BL] scsi

sindi keesan keesan at sdf.lonestar.org
Sun Jan 22 16:12:21 EST 2006

I eventually got the first (Soyo) computer working with aspi8dos.sys (but 
not with aspicd and oakcdrom at the same time - IRQ conflict)?
At this point syschk, hwinfo and nssi found the scsi drive, but DOS was 
not assigning it drive letters despite having DOS partitions made with 
linux fdisk.

Today I found a terminated internal scsi cable for the other scsi 
computer, a DFI which is a year or two newer (1999 or 2000 instead of 1997 
or 1998).  It has external rather than internal CD-ROM drive (because out 
of three scsi cd burners one could not be made to work internally yet), 
and in this computer hwinfo and nssi do NOT find the drive, but syschk 
does and lists three drive letters for it (D: H: I:).

DOS does not seem to handle scsi predictably.  Linux worked perfectly with 
it in all cases.

I used BL3 to transfer BL2 (after copying over the scsi modules from BL2) 
and BL2 to transfer BL3, to the 9GB disk (scsi id 1) and will use the 2GB 
(id 0) for DOS and uclibc.  I presume uclibc will be happy with its own 
entire partition and I can try running a separate linux with it.  This 
computer has no compiler or glibc yet.  Can I compile statically against 
uclibc and also glibc libncurses etc.?

David's 1-floppy USB camera download disk won't work with linux on this 
scsi drive because it does not have my scsi card module.  But I don't 
expect to run into a lot of computers with scsi cards to which I need to 
download photos.

On Sun, 15 Jan 2006, sindi keesan wrote:

> Using David's custom scsi/usb 2.4.31 kernel (with driver for my Adaptec
> card built in) I was able to copy BL2 to an external scsi drive and boot
> to it with loadlin.  Changed mtab to /dev/sda1.
> Now I want to change the DOS hda drive to a DOS/linux 2GBscsi drive to
> which I can boot (and remove the IDE controller card that we used to
> replace bad onboard IDE card).
> I ran low-level scsi format with Adaptec utility.  Linux fdisk formatted
> the drive (3 FAT16, 1 ext2).  Linux mke2fs on sda4.  DOS fdisk can't find
> the drive. Nor can hwinfo or nssi.  Syschk crashes if I load aspi8dos.sys.
> DOS works with scsi zip and CD_ROM drives with their specific drivers and
> aspi8dos.sys for the Adaptec controller card.  Research suggests that you
> don't need a special hard disk driver.
> How do I get this drive to be recognized?
> We have 5 1-9GB scsi drives and three computers with scsi cards.  Mke2fs
> was nearly instant on the scsi partition (1GB).  The computers can all
> boot from scsi.  I set this drive with a jumper to id 0 but it is
> recognized as ID 1, so I set the scsi utility to boot from ID 1.  But I
> can't format the DOS boot partition.
> Any ideas?
> Sindi
> _______________________________________________
> BasLinux mailing list
> BasLinux at lists.ibiblio.org
> http://lists.ibiblio.org/mailman/listinfo/baslinux

keesan at sdf.lonestar.org
SDF Public Access UNIX System - http://sdf.lonestar.org

More information about the BasLinux mailing list