[BL] Linux without a hard drive, was Re: MPlayer

sindi keesan keesan at sdf.lonestar.org
Tue Jun 28 14:07:05 EDT 2005

We are trying to find a use for a 500MHz laptop Compaq Armada M700 with 
320MB RAM but no hard drive or caddy for it.  We got it to boot by 
unplugging and replugging CMOS battery.  To get it to power off and on, 
plug and unplug the power cable and make sure there is no battery in the 
battery slot (the large battery).

>> sindi keesan wrote:
>>> The computer appears to be booting properly now, so we are back to
>>> the problem of how to use it without a hard drive after booting
>>> from floppy disk.  Can we, while it is turned on, remove the floppy
>>> drive so as to insert the DVD-ROM drive?  We could then run linux
>>> from a parport zip drive, booted from floppy disk with grub, and
>>> play DVDs.
>> Usually, single drive bays in laptops are hot-swappable.

We are trying to boot it from DSL CD-ROM and then use the parport drive. 
DSL says something about floppy/cdrom while booting so presumably this 
means you can switch drives after booting.  Another laptop computer let me 
plug in the floppy drive externally after booting to DOS, and use it as 

I cannot insmod parport.o:  create_module:  Operation not permitted.

I tried this on a second laptop with CD-ROM drive and DSL would not even 
boot - Unable to handle kernel paging request at virtual address...


We have not used this computer with linux yet.  I wonder what is going on.

I have a third laptop with CD-ROM drive, which we eventually got to open 
after a lot of random poking, and it did boot DSL despite having only 24MB 
RAM (15MB of which was used as  a RAM disk - with 320MB, it uses about 
250MB as RAMdisk).  It does not boot from CD-ROM (fd or hd only) so I 
looked at the batch file for making a boot floppy on the CD (it won't work 
in DOS, just linux), and copied over rawrite to c:\utils and made a DSL 
boot disk from boot.img following their .bat file, and it booted.

I still cannot insmod a module, so I looked up my error message and 
learned that I am not root and should su and enter my password in order to 
get root privileges while logged in as user 'damnsmalllinux'.  I tried 
various passwords such as 'root' and 'enter key' and have not yet guessed 
the right one - any suggestions?  I can't think of any reason why DSL on 
CD sets the user up as user instead of root.  Maybe if you are on a 
network it would cause problems?  You certainly can't mess up the file 

The next approach is to download the 2MB pdf manual for the 500MHz 
computer to make sure we can hotswap between floppy and DVD-ROM drives, 
and then boot from David's parport zip boot disk to parport zip disk 
linux, where I already copied over mplayer to /usr/local/bin, then swap 
the DVD-ROM drive for the floppy drive.

We could also install a 10MB fs.img to PCMCIA-adaptor-CF card and chroot 
to it, to have something that would load programs faster (but not as many 

Or make a BL3 bootable CD-ROM with mplayer on it, but the zip disk lets 
you make changes.

More information about the BasLinux mailing list