[BL] no XVESA or svgalib - DOS/linux video problem

sindi keesan keesan at sdf.lonestar.org
Sat Jul 9 21:15:00 EDT 2005


On Sun, 10 Jul 2005, sindi keesan wrote:

> On Sun, 10 Jul 2005, Ron Clarke wrote:
>
>> Hi Sindi,
>>
>> On Sat, 9 Jul 2005 15:41:39 +0000 (UTC)
>> sindi keesan <keesan at sdf.lonestar.org> wrote:
>>
>>> I have an S3 Trio3D AGP video card (4MB RAM, VESA 2.0) which worked fine
>>> in another computer.  This computer has PCI ethernet and scsi cards, ISA
>>> modem and ISA/pnp sound (Awe64) and a jumpered ISA I/O card to replace the
>>> bad floppy controller and bad primary IDE controller (the master part was
>>> okay, the slave intermittent).  It is 533MHz and sometimes freezes up when
>>> I try to go into CMOS setup.
>>   <snipped>
>>>
>>> Compushow gives a runtime error 200
>>
>>    This last is because Compushow has that Pascal bug that cannot cope with a faster computer.
>> Compushow does not run on my Duron 600 but is still OK on me AMD K3 450.
>>
>> Regards,
>>         Ron
>
>

The patch is linked to a site explaining that the Turbo Pascal 7 compiler 
runtime 200 error has something to do with division by zero (I also got a 
PcPlus divide by zero error).  The details are at 
http://www.brain.uni-freiburg.de/~klaus/pascal/runner200

This bug affects computers of 200MHz and faster.  Cshow is said to 
work at 450MHz  (we have not actually tested at 475MHz).

I downloaded and unzipped and tried to use the patch:
tppatch cshow.exe

I got a German message that I think says Pascal 7 is not involved here.
Uberprufe die Datei ...e:\cshow\cshow.exe ist keine vor TP7/BP7 erzeugte 
Datei.

I tried this on edb, a DOS database program that I was told used Pascal.

Datei ist ok.
Die Datei wird jetzt gepatcht ... fertig.

EDB WORKS!   My text remains green on exit until I cls (clear screen).


There is an English documentation file explaining how the bug works, 
something to do with timing and assumptions about what happens in 55ms.
You can patch the compiler and recompile if you have the source code for 
your program.

Cshow appears to have some other problem than Turbo Pascal 7.

mo'slo /10 cshow.exe

runs cshow at 10% of normal speed.

This might also have worked with edb.

With qpv (which on this computer produces a grey/black/white pattern) I 
tried mo'slo and got a continuous whistle on top of the pattern and I had 
to reboot.  I think it uses DOS4GW to access higher memory.  I have had 
problems with this on other computers and there is also some fix.



I still am wondering what my four DOS viewers (display, pictview, qv, 
sea3) are doing that fixes the video problem in DOS and linux and whether 
there is a fix within linux itself.



Sindi



More information about the BasLinux mailing list