[SM-Grimoire-Bugs] [Bug 15509] New: kdenetwork4 4.3.4 does not compile with libmsn 4.0

bugzilla-daemon at bugs.sourcemage.org bugzilla-daemon at bugs.sourcemage.org
Mon Dec 14 17:49:04 EST 2009


http://bugs.sourcemage.org/show_bug.cgi?id=15509

           Summary: kdenetwork4 4.3.4 does not compile with libmsn 4.0
           Product: Codex
           Version: test grimoire
          Platform: x86
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: kde4
        AssignedTo: sm-grimoire-bugs at lists.ibiblio.org
        ReportedBy: julien at rozo.org


if libmsn support is requested, kdenetwork4 compilation fails with this error :

[ 33%] Built target kopete_wlm_automoc                                          
[ 33%] Building CXX object
kopete/protocols/wlm/CMakeFiles/kopete_wlm.dir/ui/wlmeditaccountwidget.o        
In file included from
/usr/src/kdenetwork-4.3.4/kopete/protocols/wlm/wlmaccount.h:23,                 
                 from
/usr/src/kdenetwork-4.3.4/kopete/protocols/wlm/ui/wlmeditaccountwidget.cpp:32:  
/usr/src/kdenetwork-4.3.4/kopete/protocols/wlm/wlmserver.h:37: error: cannot
declare field 'WlmServer::cb' to be of abstract type 'Callbacks'                
/usr/src/kdenetwork-4.3.4/kopete/protocols/wlm/wlmlibmsn.h:32: note:   because
the following virtual functions are pure within 'Callbacks':                    
/usr/include/msn/externals.h:330: note:         virtual void
MSN::Callbacks::gotInboxUrl(MSN::NotificationServerConnection*,
MSN::hotmailInfo)                                                               
/usr/src/kdenetwork-4.3.4/kopete/protocols/wlm/ui/wlmeditaccountwidget.cpp: In
constructor 'WlmEditAccountWidget::WlmEditAccountWidget(QWidget*,
Kopete::Account*)':                                                      
/usr/src/kdenetwork-4.3.4/kopete/protocols/wlm/ui/wlmeditaccountwidget.cpp:44:
warning: unused variable 'config'                                               
make[2]: ***
[kopete/protocols/wlm/CMakeFiles/kopete_wlm.dir/ui/wlmeditaccountwidget.o]
Error 1              
make[1]: *** [kopete/protocols/wlm/CMakeFiles/kopete_wlm.dir/all] Error 2       
make: *** [all] Error 2



Compiling with libmsn 4.0-beta8 works

-- 
Configure bugmail: http://bugs.sourcemage.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the SM-Grimoire-Bugs mailing list